Jump to content
Octapus

Sync lost: Password of data on OneDrive is required

Recommended Posts

Hi there

A few days ago, all devices (mac & iPhones) keep asking for a OneDrive password (what?) "Password of data on OneDrive is required"

Needless to say i have not changed my password

Any thoughts?

Enpass 6.4.0 and macOS 10.15.4

Thank you in advance

Share this post


Link to post
Share on other sites

Hi @Octapus,

We are sorry for the inconvenience caused to you.

Please note that Enpass ver6.4 has a few changes w.r.t implementation of One-Drive sync because we have introduced support for One-Drive for Business. If you're experiencing issues with One-Drive sync, please update Enpass to the latest version on all the devices and disconnect the sync. After disconnecting, set up sync on all the devices with the same One-Drive account, and the data will sync as before. If you have any issues, please follow the help article here. Please revert us back if the problem persists.

Thanks!

Share this post


Link to post
Share on other sites

Hi Garima and thank you for your reply

All apps on all my platforms are updated and then disconnected from sync with OneDrive, but it seems i have another odd problem when i try to sync back: when Enpass call my browser (latest Chrome version) to login to Microsoft page, a couple of seconds later (and before i have the chance to provide username and password) the attached notification appears, and when i refer back to Enpass the sync is ofcourse still disconnected.

I even tried to uninstall the browser enpass extension but it didn’t help

I'm still a frustrated user :(

Screenshot 2020-03-27 at 9.59.20 AM.png

Edited by Octapus

Share this post


Link to post
Share on other sites

Hey @Octapus

Sorry to hear that.

We've released an updated version of Enpass. Could you update the app to the latest version on all of your devices and let us know if you're still encountering the same issue with the app?

Thanks.

Share this post


Link to post
Share on other sites

Hello,

I have the exact same defect.
I reinstalled enpass, but the error remains.

I am supposed to enter the password from the data on One-Drive, I did not change it.
It's not working.
This is a disaster for me.

 

Edited by Benqer

Share this post


Link to post
Share on other sites

Hi @Benqer,

We regret the inconvenience and understand that you’re facing issues with OneDrive sync. Please follow the below steps to restore the sync:

  • Take a manual backup of the data on both the devices.
  • Disconnect the sync on all devices.
  • Remove the folders Enpass and Enpass1 on OneDrive account.
  • Log in to the site https://account.live.com/consent/Manage with the same Microsoft account and delete all the permissions for Enpass.
  • Re-set up the sync with OneDrive on all the devices and check.

If the issue persists, please let us know.

  • Like 1

Share this post


Link to post
Share on other sites

I took the above steps and it did not work. Then I deleted the database when disconnecting from OneDrive. The next time I tried my Win10 computer and 2 Samsung phones (S9 & Note 8) connected and synchronized. However, I did all of the above, except going into OneDrive and deleting all the permissions, a few days ago and it worked as well. Then this morning nothing could synchronize again. It works for now, but not sure how long.

Share this post


Link to post
Share on other sites

@Pratyush Sharma

I've had the same issues for the past week. I followed the steps above on Friday and by Saturday I got the "Sync Error, Password of data on OneDrive is required." I realized I had the app on an iOS device that I didn't use, so I removed the valuet and deleted the app on that device.

Now I'm using it on only 2 device, my Mac and my Android phone. I followed these exact steps below and not less than 24 hours afterward I got the sync error again.

 

Android Mobile 6.4.3.334

  • Removed sync on Android device.
  • Reset and Removed Vaults from Enpass
  • Cleared Data/Cache on the App


Mac 6.4.1. (642)

  • Disconnected Sync
  • Marked "Also remove Data from OneDrive"
  • Clicked Disconnect
  • Enpass Folder in Apps on OneDrive was gone.
  • When to https://account.live.com/consent/Manage
  • Selected the Enpass item
  • Removed permissions
  • Closed the Enpass App
  • Relaunched Enpass
  • Setup Sync and waited for sync to completed
  • Restored account from OneDrive on Android

Clearly there is some issue, what can be done to resolve this? I'm using the personal 5 user Office 365 subscription.

Share this post


Link to post
Share on other sites

Hi @Mikey2233,

Sorry for the trouble you are going through.

We want a little more input from your side, so please take the backup of your Enpass data and perform these steps:

  • Disconnect sync from all the devices.
  • Download the debug version of Enpass from this link on your Mac.
  • Now open Enpass --> Settings --> Advanced --> Logs --> Enable it.
  • Now sync with OneDrive. When you receive an error code --> Go to Advanced settings --> Logs --> Copy the Logs in any text editor and share with us on support@enpass.io.

Thanks for your co-operation.

Share this post


Link to post
Share on other sites

@Pratyush Sharma

I followed those instructions yesterday installing Enpass Beta 6.4.0 (7) and now 36 hours later it's still syncing properly with OneDrive. I do get a message that an update is available and it wants me to update to Enpass 6.4.1.641. Should I do this?

Share this post


Link to post
Share on other sites

The same problem Here.

Version: Enpass Beta for MacOS 6.4.1(641)

"Sync Error:Password of data on OneDrive is required", I  deleted Enpass files in OneDrive and sync successful.

But then, I add new password records (trigger automatic sync, in the meantime, my network changed)

It shows "Sync Error:Password of data on OneDrive is required" again.

FhxKXdK.png

Edited by xxyzzee

Share this post


Link to post
Share on other sites

I have exactly the same problem that I reported to support the other day (Ref ECS-13697). Affecting PC (Win 10), iPhone & iPads. I was told to carry out the same procedure as Mikey2233 above, but was unsure if "Disconnect sync from all the devices" included my PC as well as phone/tablets. Queried with Pratyush Sharma, but waiting for a reply.

Update: Just had an email from Enpass Support about ECS-13697 to say that as I had not replied within 72hrs (which I had), they've closed the case!

Edited by SteveNew User
Update

Share this post


Link to post
Share on other sites

I had the same issue. The only solution I've found was to stop synchronisation from the most current device (just to be sure) and have it delete all data stored by Enpass from my onedrive account (It should ask wether you want to do that.). After that, I've setup sync again and suddenly all my devices were able to sync.

Note: I've backed up (export as .json) my local passwords as a precaution before doing the above steps. The .json file is not encrypted, store it in a secure location or delete it after fixing the sync issue.

Edited by Marbleboot
  • Like 1

Share this post


Link to post
Share on other sites

Hey @SteveNew User

Glad to hear that you have managed to resolve the issue. Also, I would like to share that an enpass team member reverted to you on the same ticket your created. Please revert us back if the same issue comes again.

Thanks.

Share this post


Link to post
Share on other sites

Hey @Lürgen

Welcome to the forum!

We want a little more input from your side, so please take the backup of your Enpass data and perform these steps:

  • Disconnect sync from all the devices.
  • Download the debug version of Enpass from this link.
  • Now open Enpass --> Settings --> Advanced --> Logs --> Enable it.
  • Now sync with OneDrive. When you receive an error code --> Go to Advanced settings --> Logs --> Copy the Logs in any text editor and share with us on support@enpass.io.

Thanks for your co-operation.

Share this post


Link to post
Share on other sites
On 4/29/2020 at 10:48 PM, Mikey2233 said:

@Pratyush Sharma

I followed those instructions yesterday installing Enpass Beta 6.4.0 (7) and now 36 hours later it's still syncing properly with OneDrive. I do get a message that an update is available and it wants me to update to Enpass 6.4.1.641. Should I do this?

@Pratyush Sharma

Enpass had been working fine up until today, and now I'm getting the dreaded "Sync Error. Password of data on OneDrive is required"

As directed I've send the logs to support@enpass.io.

Share this post


Link to post
Share on other sites

I have the same issue, but with Dropbox. Exactly the same behaviour though.

My setup uses Enpass (latest versions) on Windows 10 and Ubuntu, and sync-ing on one seems to knock out the password on the other. The only way to resolve it is to disconnect the vault (including deleting the data on DropBox -- otherwise it fails), and re-connecting.

Share this post


Link to post
Share on other sites

Hey @ThomasG

Sorry for the trouble you are having.

Please share the following details so that we can investigate where the problem could be.

  • On which devices and OS versions (mention all) are you using Enpass?
  • Which Enpass version are you using on each device?
  • Are you getting same error message or code "Sync Error. Password of data on Dropbox is required" during sync?
  • Are you disconnecting the sync on all the device to resolve the issue?

Thanks.

Share this post


Link to post
Share on other sites

Is there any update on this issue? It's been two months since it was first brought up. I'm on 6.4.2. Syncing passwords across devices is one of the reasons I switched to Enpass from KeePass and I would think a fix for this would be a priority.

I really hope there is more of a focus on quality and testing going forward. Since buying Enpass in April 2019 I feel like more issues in the last six months have impacted me that should have been caught in testing for an application as important as a password manager that us

* Touch ID not working in December 2019

* Password generator generating one password and copying it to the clipboard and then saving a different one to the vault

* One Drive sync breaking

Share this post


Link to post
Share on other sites

Hey @Mikey2233

Thanks for the patience.

The last logs provided by you was incomplete.Please turn on logs and then wait for this issue to happen and then send them back to us. Either issue is related to changing the password or one-drive expiring our access_tokens before time.

We want a little more input from your side, so please take the backup of your Enpass data and perform these steps:

  • Disconnect sync from all the devices.
  • Download the debug version of Enpass from this link.
  • Now open Enpass --> Settings --> Advanced --> Logs --> Enable it.
  • Now sync with One-drive. When you receive an error code --> Go to Advanced settings --> Logs --> Copy the Logs in any text editor and share with us on support@enpass.io.

Thanks for your co-operation.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...