Jump to content
Octapus

Sync lost: Password of data on OneDrive is required

Recommended Posts

On 6/27/2020 at 11:10 PM, Fabio said:

@mark chang yes of course. I'm syncing on gdrive and everything is ok on all my devices except the one I'm using to help Enpass Support to solve onedrive issue. My 'official' cloud service where I have all data is OneDrive. Gdrive and google are not my first choice. I'm syncing there only due to this emergency status.

@AnthonyJT you're right but I paid for Enpass :-D and most important, I like it. I work in a software house and I know the importance of data get from debugger :-D

I paid for Enpass too however, my first priority is to have access to my data and secondly to have it synchronised across my devices. Many of us use OneDrive as our primary method of sync. This issue, between Enpass and Microsoft needs to be sorted out by Enpass. The lack of transparency about what is going on is worrying.

Share this post


Link to post
Share on other sites

Hey @Captain_Eric

We are really sorry for the trouble.

We are investigating the issue and looking for a fix. Meanwhile, if possible, you can help us with the inputs using the below method-

  • Disconnect sync from all the devices.
  • Download the debug version of Enpass from this link for Windows device.
  • Now open Enpass --> Settings --> Advanced --> Logs --> Enable it.
  • Now sync with One-drive. When you receive an error code --> Go to Advanced settings --> Logs --> Copy the Logs in any text editor and share with us on support@enpass.io.

Thanks for your co-operation.

Share this post


Link to post
Share on other sites

My wife got this last week. I fixed it myself by disconnected everything and finding out there were multiple Enpass vaults file in OneDrive. Also, they were in multiple various locations one wasn't updated since 2017 so I knew it was safe to delete.

Now today I noticed mine stopped working and its asking for OneDrive creds, broke on Win10 2004 and iPhone latest iOS. I will investigate fixing this tomorrow same way I did my wife's Surface Laptop 3 Win10 2004/iPhone/iPad.

  • Like 1

Share this post


Link to post
Share on other sites

I had the same issue today on my Linux PC and Samsung S9+ phone... for whatever reason both just started requesting for password on OneDrive data in order to sync. Same as others, I haven't re-encrypted the data using some different password. Tried to delete everything from OneDrive, remove application access for Enpass on OneDrive and then re-establish the sync, but that didn't help, so only switching to different cloud service (DropBox) solved it.

Hopefully this is just temporary issue, because I really enjoy and appreciate the way Enpass just works... for years.

Share this post


Link to post
Share on other sites

Hi @zdravkos74,

Sorry for the trouble you are going through.

Our Dev team is working on it. Hopefully, fix will be available in the future update. Till then, we will request you to please co-operate with us.

Thanks!

Share this post


Link to post
Share on other sites

I had the same issue today on my windows and android phone,

I downloaded vault.enpassdbsync from onedirve to my phone,

and then used enpass to open the local vault.enpassdbsync, but still prompted the wrong master password.

google translate

Share this post


Link to post
Share on other sites

Hey @frankttz

Sorry for the trouble.

Please follow the below steps to restore the Enpass data from cloud-

Open Enpass and create a new vault --> Click on Restore from the particular cloud --> Login the cloud account--> Click on Continue --> Enter master password (same you using before)--> Tap on 'Continue'.

If the problem persists, please share the following details so that we can investigate where the problem could be.

  • On which all devices and OS versions (mention all) are you using Enpass?
  • Which Enpass version are you using on each device?
  • Are you able to access all Enpass data on any of the devices?

Thanks!

Share this post


Link to post
Share on other sites

Same problem saying OneDrive password is invalid.  I'm using latest Enpass on 2 PCs (Windows 10 2004), 2 Android phones.

Followed directions to Disconnect on all devices and then reestablish.  No success.  It still says the OneDrive password is invalid.

Followed recent directions to create a new Vault and Restore.  No success.  Still says invalid OneDrive password.

This thread has been underway with this problem since March and it is now the end of July!   This is utterly disgraceful.

Please give us a target date as to when you expect this to be fixed.

 

Share this post


Link to post
Share on other sites

Hey @RASTPB

 We really understand the trouble you are going through and apologize for the same. Our team was working their best to investigate and fixing this issue. To resolve this issue, our team will soon be releasing an update with the fixes. Please stay tuned for the latest update and share your findings.

Meantime, please try the workaround given below-

On 7/20/2020 at 12:30 PM, Martin6800 said:

Hello everyone! I have now found a solution for myself. Had the same problem the last few weeks. Check if you have another folder on OneDrive, in the Applications folder, Documents, or directly on OneDrive. This one was available to me three times. I deleted all folders and turned off synchronization from all devices. After that, the synchronization worked right away on my iPhone SE. Now a new "Enpass" folder has been created in the "Applications" folder.

Thanks for understanding.

Share this post


Link to post
Share on other sites

I fixed this by turning of sync on all devices, removed the faulty sync_default.walletx. Turn on sync again. Locks like all changes I did on the devices where synced correct! The error disappears.

  • Like 1

Share this post


Link to post
Share on other sites

This happened to me twice now in the past week, and I'm getting sick and tired of fixing it.

I've been a long-time - and enthusiastic - user of Enpass, but this is trying my patience.

Share this post


Link to post
Share on other sites

Hi @waynezen,

Sorry for the inconvenience caused to you.

We have identified the bug. A fix for the problem will release within a week or so with the Beta version 6.5 for the desktops. Till then, we will request you to please co-operate with us.

Thanks!

Share this post


Link to post
Share on other sites

Hey,

 @lesefreudig Thanks for sharing your feedback of beta version. We understand the inconvenience you are having with this and apologies for the same.

Please confirm if you had deleted Enpass folder from One-drive and then enable sync. To do so please follow these steps:

1. Disconnect the sync from all devices.( Connected with the same One-drive account).
2. Open One-drive in any browser --> Go to Apps --> Enpass --> Take the backup of Enpass folder and Delete Enpass folder. ( Delete all Enpass folder).
3. Now open Enpass and enable sync and let me know If the problem persists,

Thanks for understanding.

Share this post


Link to post
Share on other sites

So I had the chance to try it out. I uninstalled enpass from all devices, deleted everything from onedrive and then reinstalled.
The good news is that it now works on five devices. The bad news is that it just doesn't work on my company computer.I have One drive installed on my company computer and it is connected to my company account.  Maybe that is why it does not work. But in the old version, just a few weeks ago, it was no problem to use it on my company computer.

Edited by lesefreudig

Share this post


Link to post
Share on other sites

I had that error for the first time today (Windows 10, Enpass 6.4.3, OneDrive).

Out of nowhere sync failed.

Here is what I did:

  1. made a lokal Backup on my WIndows 10 Computer
  2. looked directly in OneDrive: There where 2 Folders: "Enpass" and "Enpass 1"
  3. made a backup of both in zip Files
  4. disconnect sync with doption to delete sync file on one drive (to look which of the folders would be erased: "Enpass 1")
  5. deleted remaining folder "Enpass" directly in OneDrive
  6. created new sync connection with one drive
  7. sync

 

Everything was immediately back to normal:

  • there was no need to do anything on the other devices, no reset, no disconnection, nothing
  • all other devices could immediately sync, as if nothing ever hapened

 

My conclusion:

Enpass simply corrupts the sync file on the server, for whatever reason

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...