Jump to content
Enpass Discussion Forum

Since Enpass update 6.5.2 (725) unable to ...


Recommended Posts

  • 3 weeks later...
  • 3 weeks later...

I just wanted to add to this, that this issue affects not only the chrome extension bu also the firefox extension. And also it is not only affecting cpanel login on port 2083 but also login to WHM on port 2087 (cpanel admin/management/reseller backend)

 

You can access a demo of the WHM login form here: https://trycpanel.net/logout.html

 

b.r. Haddi

  • Like 1
  • Thanks 1
Link to post
Share on other sites
  • 1 month later...
  • 2 weeks later...

@afunworm Our team has fixed similar issues in the next extension update. Please wait for the same version to be released and then share your findings with us. Meanwhile, your co-operation will be highly appreciated. Thanks!

@celavakosa It would be a great help if you can explain this scenario a bit more, it will help in a clear understanding before further proceedings.

Link to post
Share on other sites

@Pratyush Sharma I thought issue was pretty clear and well understood but I'll explain it in as much detail as I can. Also I must agree with other posters in this thread, I am using various cpanel products almost every day and logging in to those is a big reason for needing a password manager with auto filling browser extension in the first place so one must indeed explore other options if no updates will be made soon.

A server with cpanel installed has (at least) two management web gui's, one is accessible on exampledomain.tld/cpanel or exampledomain.tld:2083 and that is the customer facing one commonly known as Cpanel. The other one known as WHM or Web Host Manager gives access to more low level stuff in the server config as well as managing customer and reseller access to the customer portal and is accessible on exampledomain.tld/whm or exampledomain.tld:2087

The issue for both of these is the same, when I press my shortcut for the browser extension I get the window and it shows the correct entry, but when I double click on it to auto fill nothing happens. Also I have checked and nothing gets printed to JS Console error log or anything else I can find.

This leaves the only working way for me to bring up the browser extension, clicking the info icon and then manually copying the password from enpass to paste it in the login window.

Again, if you want to try this out your self there are demo's of cpanel available online that behave in the exact same way, that is you can try creating a dummy entry for them in enpass and auto filling on these url's and it will not work, just like on my own servers as well as on cpanel servers hosted by others that I have had access to.

Cpanel online demo login:
https://demo.cpanel.net:2083/

WHM online demo login:
https://trycpanel.net/logout.html


Best regards and hope you can fix this soon, Haddi

Edited by haddi77
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...