Jump to content
Enpass Discussion Forum

Enpass not syncing with OneDrive


Recommended Posts


Using the same enpass acount, and the same OneDrive Vault account, and using the most up to date versions of Enpass installed on two devices: 1) Android; 2) windows 7 desktop;

It is not syncing properly. I've been using Enpass for many years and haven't had any issues.

Currently my desktop has 145 logins; I click 'sync' and all appears to be working. no error messages.

Currently my android has 143 logins; I click 'sync' and the missing 2 should "appear". But they don't. 

The desktop does not appear to be "pushing" to the cloud the two missing logins.

Any help?


Link to comment
Share on other sites

  • 1 month later...

Are there any updates on this issue? I am having the same problem with windows, android and OneDrive.

I think, the problem is not that the desktop is not pushing but android is not pulling. I synchronize over two desktops and one android and the sync between the two desktops is just working fine.

I also noticed that clicking the sync button on android does not work most of the time. Nothing happens when clicking it. This is always the case when entries are missing and not being updated.
If the sync worked - which happens from time to time - and the entries are updated, the sync button works for a short time and updates the last synchronized message.
@sapbucket Do you also experience unreliable syncing from time to time?

Maybe @Garima Singh can take a look at this issue?

Link to comment
Share on other sites

Hi @mP7

Sorry for the inconvenience caused to you.

Please check if the date and time on your device are accurate. Make sure date and time preferably set to automatic on both the devices.

If the issue persists, disconnect the sync from all the devices and reconnect it again. Now do some sample change like add a new item in both the devices device. Now check does the changes are reflected in other devices?

Also, I am assuming that you're checking items count from the vault information page, accessible from Enpass Settings --> Vaults --> Select Vault and Under Vault settings, you'll see count of vault items and attachment.

Thanks for your co-operation.

Link to comment
Share on other sites

  • 2 months later...

Hi @Pratyush Sharma,

Sorry for the delay.

Date and time are set accurately on all devices and are set to automatic.

I tried disconnecting the sync from all devices and reconnected it again. This did not affect the described behavior.
The sync still is not reliable and pressing the sync button on Android most of the time does not do anything – or at least nothing is indicated.

After a while the sync usually works but thus the Enpass app gets quite unreliable. It’s also very cumbersome to check all vaults since I always set it to ‘all vaults’ and there is no option like sync all.
It very rarely happens that Enpass automatically syncs new or changed entries by itself. I most of the time have to do something manually in order to get the updates.

I usually do not check the sync status the way you described. I mostly open the hamburger menu and tap on the cloud icon. In this windows, I can check ‘las synced’ and press the sync button.

Link to comment
Share on other sites

Hi @mP7,

Thanks for sharing the inputs.

I understand that your Desktop and Android device are not syncing. The reasons could be:

  1. Desktop is syncing with a OneDrive account different than your Android devices. In case of Microsoft OneDrive, they could have same email address but different account type (Personal or Work/School).
  2. It is syncing to same OneDrive account but to different folder than the Desktop devices are.

Don't worry, we can solve this issue by checking both the above reasons one by one. 

  1. Make sure if all devices are syncing to same OneDrive account by looking into Enpass sync-setup page. All devices should show same OneDrive account ID. If it is showing different account, please disconnect sync in Enpass and reconnect. Please note that your browser has remembered your OneDrive account, so before connecting sync again, please log out from your OneDrive account on browser.
  2. To look for second reason, you need to login to your Microsoft OneDrive account on browser and check for Enpass folders. 

Please check for both reasons and share your findings.


Link to comment
Share on other sites

  • 1 month later...

I'm seeing similar behaviour on Android.

I've captured a screenshot of what I see when the Android app gets into the 'broken' state. If I try and force the sync, i get a small grey 'blob' at the bottom of the screen that appears, and then goes away after a second. It's almost as though there is an error message being suppressed.

You'll also notice in the screenshot that the last sync date/time goes missing.


To recover, I can either Force Stop the Enpass app and relaunch, or simply reboot my phone/tablet.

I encounter this on both of my Android devices at least once a week.

Is there something we can do to capture data to send to the dev team to troubleshoot this problem?


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...