Jump to content
Timo K.

iCloud Sync does not work despite connection

Recommended Posts

Since the update to version 6.4.0 I have a problem with the iCloud Sync. The connection to iCloud exists (in the settings I see the "Trennen" button (means: disconnect)), but my name and informations about the last sync are missing. 
I need to disconnect from iCloud once a day and reconnect afterwards. 

Before disconnecting:

image.png.51512da0013d1d795c2944d466dafa66.png

 


After disconnecting and reconnecting:

image.thumb.png.b4a395579e053850c209f4c6a0ab1268.png

 

This problem only occurs on my Windows 10 (Pro Version, 64 bit, Version 1709) computer.

I hope, anybody could help me.

Regards,

Timo

 

Share this post


Link to post
Share on other sites

Hi @Timo K.,

Welcome to the forum.

We are sorry for the inconvenience caused to you.

For security reasons, your iCloud session expires periodically. To avoid this, you first need to disconnect the sync with iCloud from Enpass settings, then again enable it, and you’ll be redirected to the iCloud login page. Here you just have to enable “Keep me signed in”. For more details, please click on this link to see the screenshot.

Hope this helps.

Share this post


Link to post
Share on other sites

Hello @Garima Singh,

thanks for the feedback. 
I have been using Enpass for over a year now and know that the session expires regularly, so that's okay form me.
But since the update there is a bug in it. Normally the session expires about every 4 weeks and I get a red information text the iCloud session has expired. But since the update, I have to disconnect and reconnect every day and I don't get a message that the session has expired (see the first screenshot).  Instead, it always looks like the session hasn't expired yet, but the sync still doesn't work and I get the "Disconnect" button ("Trennen" in the screenshot).

 

Do you now and see, what i mean?

Regards,
Timo

Edited by Timo K.

Share this post


Link to post
Share on other sites

Hi @Timo K.,

We are sorry for the inconvenience causing to you.

Could you please disconnect sync form all the device and make another browser your default browser and then try to sync again with the iCloud. If the problem still persists, please share the following details so that we can investigate where the problem could be.

  • On which devices and OS versions (mention all) are you using Enpass?
  • Which Enpass version are you using on each device?

Thanks for your co-operation!

Share this post


Link to post
Share on other sites

No, unfortunately the problem is not fixed, but I am glad that I am not the only one with this problem :(

I am using Enpass (Pro Version) on Windows 10 (this is where the mentioned problem exists), on my iPhone 6 (iOS 13.3.1) and my MacBook Air with the current MacOS version (version number is not known at the moment because I don't have the device here). All devices are connected via the iCloud. 
Enpass itself is always updated, so I always use the current version. On Windows and the IPhone the version 6.4.0 is currently running.

@Garima Singh Obviously we need help from the Enpass team :(

Share this post


Link to post
Share on other sites

I too have this same problem with iphone sync on my windows 10 laptop, a Dell tablet running windows 8.1, and two Desktop PCs running Windows 7.  All of my systems are running 6.4.0.  On my systems I can replicate the problem by shutting them down, powering them back up, and then try to sync.  Like Timo K reported above my name and information about the last sync are missing. It's  as if Enpass doesn't know what to sync.  I need to disconnect from iCloud and reconnect to get sync working again.  KP

  • Like 1

Share this post


Link to post
Share on other sites
I have the same problem. I use Enpass 6.4.0 (632) with Windows 10 Home 1909. I also use Enpass on multiple IOS devices. I use 6 different safes and sync them with iCloud (4x), Onedrive (1x) and Dropbox (1x). Not only does iCloud sync stop, the Dropbox and OneDrive safes also stop synchronizing. The synchronization of all vaults continues to function normally on the IOS devices.
Edited by Dennis J

Share this post


Link to post
Share on other sites

Hello @Timo K.,

We have identified the issue with the iCloud sync and are working on an update with the fix for it. You could let us know if there's anything else.

Thanks.

  • Like 1

Share this post


Link to post
Share on other sites
14 minutes ago, Timo K. said:

Hey, Enpass Team,

thank you for solving the problem. Since the last update the sync function works again without problems :)

The same experience for me. The iCloud, Dropbox and Onedrive synchronization will now continue to function correctly on Windows 10 Home Edition / Enpass 6.4.1 (642). Thanks for solving.

  • Like 1

Share this post


Link to post
Share on other sites

Hi All,

Thanks for the co-operation.

We've released an updated version of Enpass since this issue. Could you update the app to the latest version and let us know if you're still encountering the same issue with the app?

Thanks.

Share this post


Link to post
Share on other sites

Hello,

I still have that problem that the iCloud session expires. This only happens on Windows 10. I have epass 6.41.642.0. According to the windows app store it's the latest version. But it doesn't seem to contain that fix. So when I reconnect to iCloud the synchronization works again, but on the next morining I am told that the connection has expired. DUring the reconnetion procedure the browser that is used to establish the connection between iCloud and enpass doesn't seem to finish the procedure. After the enpass app starts resynchronizing the browser is still idle with the spinning circle

image.png.bc2937bc8386379f83cc2d39fb936156.png

this goes on forever. So to me it seems as if the reconnect procedure is not complete that that's why the connection expires all the time. I hope that this is resolved soon.

 

Thx

Hans

Share this post


Link to post
Share on other sites

Hi @rednewsch,

Can you please let me know have you enabled the "Keep me signed in" option while authenticating the iCloud login credentials during the sync process? For more details please refer to this FAQ.

Thanks for your co-operation.

Share this post


Link to post
Share on other sites

Hello,

well, this is the problem. As I said, the browser is stuck with the spinning wheel (see my screenshot) and won't show me the "Kepp me signed in" option on Windows. I tried Firefox and Edge. On iOS the synchronization does always work, no need to sign in again. I could try on MAC OS which I'm using at home.

Thanks

Share this post


Link to post
Share on other sites

Hey @rednewsch

Sorry for the trouble.

I have notified the issue to the QA team. Meanwhile, you can try disconnecting the sync on the macOS device, now take the backup of Enpass data and then reinstall Enpass. After reinstall, restore the Enpass data and then set-up sync again.

Thanks.

Share this post


Link to post
Share on other sites

Hello,

I have tried and uninstalled Enpass and reinstalled, connected to iCloud for synchronization. Nothing changed syncrhonization works now, but tomorrow the iCloud sync will be expired again. The browser is still ideling with the spinning wheel and I don't get the opportunity to select the "Keep me signed in" option. I can confirm this now for FIrefox, Google Chrowe and Microsoft Edge browsers. I have relaxed the browser settings for security to make sure nothing gets blocked.

Share this post


Link to post
Share on other sites

Hey @rednewsch,

We are sorry for the inconvenience causing to you.

Our QA team has reproduced the issue and now our Dev team is working on to towards a fix. Hopefully, a fixed version will be available soon.

Thanks for the co-operation.

Share this post


Link to post
Share on other sites

Hey @rednewsch

Our team confirmed that they have fixed the issue in Enpass v6.4.1. Could you update the app to the latest version and let us know if you're still encountering the same issue with the app?

If the problem persists, please share the following details so that we can investigate where the problem could be-

  • On which device and OS version are you having this issue?
  • Which Enpass version are you using on the same device?
  • Does the Date and Time setting set to automatic on all devices?
  • Does the last synced time get updated on the sync page?
  • If possible, please share the screenshot of the issue/error?

Thanks.

Share this post


Link to post
Share on other sites

Hi,

I have updated to the recent version 6.4.2 (662). But nothing changed. When I set up synchronization with iCloud Epass opens the browser for me and I am asked to provide the login information for my icloud account. Then I have signed on the I still get the spinning wheel and there is no way to check the "Keep me signed in" option, because I am stuck with that spinning wheel. Synchronization works though. But the connection will be timed out again and I have to sign in again with Enpass for iCloud synchronization.
It looks like this, after I sign in with my iCloud credentials:

image.png.767e538641f4f9b4b0285d024bc9bd66.png
I checked: It works on iOS, it works on MAC OS X (Catalina), but not on Windows 10 Pro.

  • The issue occcurs on a Laptop Computer, running Windows 10 Pro
  • Enpass Version 6.4.2 (662)
  • Not sure what you are asking about time an dat setting. Is it a setting in Enpass or an OS setting?
  • I can see the last syn time on the sync page
  • The screen shot would be the same as shared earlier: The spinning wheel on the browser page waiting for completion of the sign on via this api. What does not happen is: I don't get the opportunity to check "Keep me signed in". And this is why I have to reconfigure the iCloud sync setting every day. Which sucks.

One more thing that might be interesting: I use multi factor authentication for iCloud.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...