Jump to content
Enpass Discussion Forum

Enpass is freezing running on Mac OS Ventura using the M2 Chip


Shlomi
 Share

Recommended Posts

Hello,

I bought this app some time back and have one vault saved on Google Drive. Whether I downloaded the app from the app store or the website, I consistently face an issue: the app freezes upon reopening. The problem doesn't arise if the app is not opened at all, but if it's already running and I use my fingerprint to log in, it becomes unresponsive. As a workaround, I deactivated the automatic check for new versions, which alleviated the issue slightly, but the problem persists intermittently. I also tried disabling the browser popup as suggested on the forums, but to no avail.

Interestingly, when I use the app on another computer with Mac OS Ventura on an Intel chip, and on Windows as well, it operates smoothly.

I'd appreciate any assistance to continue using this app without hitches.

Edited by Shlomi
Link to comment
Share on other sites

Hi @Shlomi

For troubleshooting purposes, please create a manual backup of your Enpass data and then reinstall the app. If the issue persists, kindly share the below details and I will get this checked for you -

  1. The version of the Enpass app, OS, Enpass Extension and browser you are using.
  2. Does the Enpass app freeze after a certain action? Like opening a webpage, editing an Item, etc, or is it completely random?
  3. The total number Items, vaults and attachments you have saved in the Enpass app.
Link to comment
Share on other sites

Hello

1. Enpass version is 6.9.0, the operating system is Macos Ventura 13.4 <acbook Pro M2 chip, the os is chrome (i am not using extensions for passwords)

2. The app freezes if i do not totally quit it, but rather open it again, authenticating using the finger print. (To fix this i force quite and login using the password, and that is also sometimes does not help)

3. I have around 180 items, i have 1 vault on google drive, no attachments.

I have just granted full disk access to Enpass (made a quick 1 test and it did not freeze, need to check again in an hour after system sleeps and i reactivate the app again from sleep), might it be having issues updating local copy when reactivated?

On my intel based macos ventura i do not have full disk access and it works fine thou.
I will post here if it helped, but would love to know if others with M2 are having the same issues.

Regards,

Shlomi

Edited by Shlomi
Link to comment
Share on other sites

10 hours ago, Shlomi said:

...would love to know if others with M2 are having the same issues.

Just had a quick look Shlomi and neither my Intel Mac mini nor my M2 Pro Mac mini have Full Disk Access enabled for Enpass. 

Both machines are running Venture 13.5.1 and Enpass 6.9.0 (Mac App Store version).

Link to comment
Share on other sites

  • 2 weeks later...

Where will I find this crash report? I have changed settings to keep enpass active all the time (not a good practice) so i will not get it frozen.

There is no logs or enable logs in advanced settings.

Another weird thing happening sometimes, tags are being removed from certain records, mainly after a freeze, i need to reapply them all over again.

Link to comment
Share on other sites

Hi @Shlomi

Allow the Enpass app to become unresponsive. Once it does, perform a force quit on the application . You should then see the crash report which you can share with us.

In regard to the issue of tags disappearing, our development team is actively addressing this bug and working on a resolution. To stay updated on our progress and receive notifications when we post updates about the fix, you can follow the forum linked below -

 

Link to comment
Share on other sites

Hi @Abhishek Dewan

I tried to do exactly like described below but it did not help

 

I just noticed that if i unlock with the Touch and instead of going to an item, i am opening the settings at first, then closing it and choosing an item it is working fine.

So i unlock the app with my finger, i go and press the cog wheel, close it and then i browse my tags, seems to work without being stuck.

Also I noticed that it does not happen when i use the password instead of the PIN or the Touch, if I unlock the enpass with the master password then i can browse my tags freely, hope it helps to pinpoint the issue further.

There was a setting of creating crash logs in old versions, it is removed now, so I do not see how i can share a crash report. It does not being created at all not when i force quit from the dock or from the "Activity Manager" process section

 

Regards,

Shlomi

Link to comment
Share on other sites

Hi @Shlomi

Thank you for sharing the feedback with us.

As we investigate the comments and attempt to replicate the issue on our side, please consider the following steps to see if the crash report becomes visible - 

  1. Please check and ensure that you have install the Enpass Store version- 6.9.0 (1466). If not, kindly create a manual backup of your Enpass data, then install this version and restore the data from the backup file.
  2. Allow the Enpass app to become unresponsive. Once it does, perform a force quit on the application
  3. Now go to macOS Library>Logs>DiagnosticsRepors>--------.ips
  4. Share the Crash file (Feel free to DM me the file)
    image.thumb.png.79f7101135380fe7133ba9cd1df75d44.png

 

 

 

 

 

 

 

 

Note - There is another way to check for the crash report: Open Console app in Mac --> Process Name Go to Crash reports under reports section --> Enpass-->Reveal in Finder

image.jpeg.ffedbcf3b64b5ca9c409f0553fca8a08.jpeg

 
Link to comment
Share on other sites

No crash reports are being generated, I am guessing that it goes into some infinite loop, having a sort of a race condition in the code.

So when it is forced quit, it still somehow closed gracefully.

Might be a good idea to give an option to disable the auto sync when activating the app, and letting the user do it manually if he/she wants to.

We are not adding passwords every minute, so this auto sync on activation is an overkill

Link to comment
Share on other sites

Similar issue here.

Brand new MacBook Pro, Ventura 13.5.2 / Enpass 6.9.0

Open, log in (using password) and before I can click anything it beachball/hangs.

Both opening from the taskbar icon or the dock breaks.

Running on old computer fine (MBP w/Intel running same versions) 

 

Link to comment
Share on other sites

  • 3 weeks later...

Similar issue here. The problem started when I upgraded to latest version of Enpass. It was working fine before on an older version of Enpass (although not sure what this was now), up until the point I upgraded Enpass. 

I am currently on MacBook Pro M1, Ventura 13.5.2 / Enpass 6.9.1 (1512). 

I'm having the exact experience Shlomi was having. Works fine if opening for the first time, but if I reopen after it has locked I get the spinning beachball of death and have to force quit the app.

(Note: seems to work fine on a separate Macbook Air M2, Sonoma 14.0 / Enpass 6.9.1 (1512), eg. exactly the same version of Enpass. Unfortunately I can't upgrade the M1 Macbook Pro to Sonoma!)

Link to comment
Share on other sites

  • 3 months later...

Similar issue here. I'm having the exact experience Shlomi and kefa was having. Works fine if opening for the first time, but if I reopen after it has locked I get the spinning beachball of death and have to force quit the app. I repeat reopening enpass three or four times. Then enpass works fine again. So sometimes it works sometimes not.

am currently on iMac M1, Ventura 13.6.3 / Enpass 6.9.3 from Apple Store. 

Are there any solutions?

Link to comment
Share on other sites

I got an update from the Enpass technical team, and I would like to share the below steps: If Enpass shows the crash dialog box "Enpass Crash Reporter" and gives an option to submit the crash report, that is fine. But if not, then the crash report can be found in the system.

Here are the steps to locate the crash report:

1. Open Console app.
2. Select 'Crash Reports' from the left sidebar.
3. Check for reports generated by the Enpass app.
4. Select the crash report, right-click, and choose "Reveal in Finder."
5. You will see the .ips file.

Please share that file with us.

Note: This request is for all the reporting users to please try this on an Enpass macOS Store version like - 6.9.3 (1592).

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...