Jump to content
Enpass Discussion Forum

First Beta of Enpass 6 for macOS is out!


Vikram Dabas
 Share

Recommended Posts

Hi @100 Watt Walrus 

Thanks for writing back. 

On 8/25/2018 at 2:11 AM, 100 Watt Walrus said:

Please add the ability to create additional "notes" fields in custom templates.

 

 

I would like to share that you can change the field type as Multiline, which will work as a Note field and I hope it'll be fulfilled your requirements.

8 hours ago, 100 Watt Walrus said:

The field name should always be next to the field, not below it. See attached image.

 

Already fixed in development tree.

5 hours ago, 100 Watt Walrus said:

Will production version of Enpass 6 allow users to chose the directories to which their vaults are saved in the cloud?

 I would like to share that in next update we're going to introduce Folder sync support, which will allow you to sync multiple vaults with the same cloud account by giving a specific folder path to each vault.

Cheers!

  • Like 1
Link to comment
Share on other sites

Great news, Anshu Kumar! Thanks. My eye went right past the Multiline option. I'm not sure I would have known what that meant had I noticed it. Maybe for clarity call it Text (Multi-Line) instead. Also, in the Field Type menu, the list should be in alphabetical order. Right now they're a jumble.

A question: Does the vault save customizations too, like custom templates? Or do those have to be recreated on each computer?

Link to comment
Share on other sites

First of all, I am really glad to see the new version of Enpass coming and it does seem promising to me. People stated that UI and UX does not feel very macOS native and I agree but it could be so much worse and I dont't think we should focus on that.

But there is something that seems very wrong to me and this is something 1password does in a similar way if I see it right: The different vaults I set up are always opened by entering one (primary) master password. My use case for multiple vaults is that I have a couple of very sensitive passwords that I rarely need to use stored in one vault and I don't want to expose them every time I open my other vaults that I use on a daily basis. Is there a way to keep a vault closed unless I really want to enter the master password to open it? Otherwise please add that functionality!

Thanks!

Edited by jankkm
Link to comment
Share on other sites

Something about the password generator I would like to share:

When I choose a pronouncable password and also choose "Digits" (plural), there is always just ONE digit added and it's always at the of the very end of passphrase. I EP 5 this seems to be more random: sometimes at the start of a word, sometimes at the end and never is it at the same position in the passphrase over and over again.

Link to comment
Share on other sites

Hi @kwitchibo,

Thanks for writing in.

Adding uppercase and digits in between words makes it less memorable without adding much to the security. Option to add them is just to satisfy requirements of some websites. An uppercase in the start is easy to remember and a digit in last can be pronounced as an additional word.

Thanks!

Link to comment
Share on other sites

I think there's an incompatibility between Enpass 6 beta and the Logitech Control Center.

System: Mac Pro 2013, macOS X 10.2.6 (Sierra), Logitech mouse Performance MX, Logitech Control Center v3.9.6

Used with Enpass 5, the mouse works perfectly, but with Enpass 6 beta, the wheel does not work as expected. When I browse the main list with the scroll wheel, at first the list is going down (or up if going in reverse) as expected, but when the scroll wheel is used again to go further down or up the list, the list is in fact sent back upward (or downward)  to where it was before the first move, then goes down (or up) again. So even after a few strokes the list is still in the same position. It seems that Enpass 6 beta is always going back to the entry that is highlighted in the list before scrolling up or down.

Using the cursor in the scroll bar by clicking and dragging it works fine.

 

I have an other maintenance partition with minimum system and applications installed, without the Logitech Preference Pane. When Enpass 6 beta is installed on that minimum system the mouse works properly.

It seems the incompatibility is between the Logitech System Preference Pane and Enpass 6 beta.

EDIT: the same issue is found when browsing the icon panel.

Edited by fermati
Link to comment
Share on other sites

On 8/27/2018 at 8:53 AM, Anshu kumar said:

I would like to share that in next update we're going to introduce Folder sync support, which will allow you to sync multiple vaults with the same cloud account by giving a specific folder path to each vault.

Great to hear that! This should solve many sync problems for now, as in this case the Dropbox/OneDrive/etc client can take care of the syncing and Enpass only needs to write the file. Is there any estimation when the new MacOS enpass beta will be available?

 

Another strange thing I noticed (hope it hasn't been reported elsewhere yet):

382493555_Bildschirmfoto2018-09-07um17_46_02.png.91d80db81ab332dc3e39e03f07188ccc.png

The "Add to vault" option (last item) is disabled when browsing the items of "all vaults" (top left of the window). So to be able to move an item from one vault to another, I first have to select the destination vault from the top left to get that option enabled. Not sure why this is necessary...

Edited by SierraFoxtrot
Link to comment
Share on other sites

As previously mentioned by 100 Watt Walrus, the categories list is not really well organized and flexible. It's really great that we can create new categories as we wish, but they should not automatically go to the bottom of the list. In fact would it be possible to allow users to reorganize that list by just dragging the categories up and down, as we can do within templates?

Link to comment
Share on other sites

There's also an issue with the custom icons quality. I know that there's still some foggy area concerning those custom icons, but even after following the Anshu kumar recommendations I still see problems.

This is how I created a few: go into the application Contents folder and find the the icon file (usually an icns file). Open it in Preview then save it as a png (icns cannot be opened in Photoshop). That png was then opened in Photoshop to be sized at 200px x 200px, at 72 dpi as recommended by Anshu kumar. 72 dpi is the resolution used by Enpass6beta for icons found in Users/username/Library/Containers/in.sinew.Enpass6-Desktop-Beta/Data/Library/Application Support/Enpass6/icons/item. I assumed that those files are used to create the icons within the application, but I may be wrong. The icons were then saved as png files, with larger file size selected. They were not flattened before to saving because the original png files from Enpass have an active Photoshop layer.

The problem is that when used as custom icons they loose their sharpness and looks like they have jagged edges. You can see this in the images below. The second one was enlarged 200% with PhotoZoom Pro 7. As can be seen in those screen captures the original icons from Enpass6 beta are looking nice, but the custom ones are not good. What did I do wrong? How are other users creating their files for custom icons?

Thank you very much in advance!

 

enpass6_icons.jpg.04d1357ee4a3b733bb32b94d0e161412.jpg

1062697570_enpass6_icons(resized).jpg.c5f66e15e15a4786b38aeb67b2cefe74.jpg

Edited by fermati
Link to comment
Share on other sites

On 9/7/2018 at 4:46 PM, fermati said:

Open it in Preview then save it as a png (icns cannot be opened in Photoshop). That png was then opened in Photoshop to be sized at 200px x 200px, at 72 dpi as recommended by Anshu kumar.

FYI, you could have saved yourself a step and just resized them in Preview. :)

Can confirm this issue though. Screenshots below from me of custom icons, made per instructions upthread.

 

1173574932_jaggedcustomicon.png.cfc7d0d33425bfc566e267c3fb553be7.png

Edited by 100 Watt Walrus
Link to comment
Share on other sites

The following is related to the web browser extension usage.

On my machine Enpass6beta is set to launch at startup. After entering the master password I hide the main window by option-clicking on the desktop. What seems to be a little odd is that every time I use the extension in Firefox to fill in a logging, the main window comes back to the front. Same thing with Safari. If it is intentional I am not sure it should be kept because every time the main window has to be hidden back to the background.

Link to comment
Share on other sites

3 hours ago, fermati said:

The following is related to the web browser extension usage.

On my machine Enpass6beta is set to launch at startup. After entering the master password I hide the main window by option-clicking on the desktop. What seems to be a little odd is that every time I use the extension in Firefox to fill in a logging, the main window comes back to the front. Same thing with Safari. If it is intentional I am not sure it should be kept because every time the main window has to be hidden back to the background.

Why keep the main window open at all? No need to OPT+click the desktop (do you know you can CMD+H to hide the foreground app?). You can just click the red (X) in the main window. Enpass is still in the Menu Bar and in your browsers if the main window isn't running. You can also hide it in the Dock (no need for it to be there since you can get to Enpass from the Menu Bar:

Settings > General > Hide dock icon when main window is closed

 

Link to comment
Share on other sites

Yeas I know command-H, but I also like the option-click.

I know I can close the window but I would prefer the old behavior so I can keep the app running in the background. That said I am not sure it is possible for the software developers to achieve that behavior.

Settings > General > Hide dock icon when main window is closed: that's the my setting ar the moment.

Link to comment
Share on other sites

I just downloaded the Enpass Beta client for macOS.  I successfully set up a "test" vault.  Now I want to set up syncing with my webdav server.  I cannot find where to set up Sync.  When I try to go to Tools>Sync, nothing happens.  Am I missing something?  I had Enpass 5 installed, but deleted it before I set up the Beta. I had no data that I needed from version 5.

 

My goal is to test syncing between my desktop and my mobile devices.

Link to comment
Share on other sites

Hi @JSF,

Thanks for writing in.

12 hours ago, JSF said:

 Now I want to set up syncing with my webdav server.  I cannot find where to set up Sync.

Please follow these steps to enable sync in Enpass 6.

  • Open Enpass --> Settings --> Vaults --> Tap Set up sync.

139821677_preview-chat-ScreenShot2018-09-12at2_54_27PM.png.63918a068ad60b30f1012926ee1e6ba5.png

NOTE: Currently there is some issue where WebDAV sync is not properly working and the fixed version will be available soon.

Thanks for your patience.

  • Thanks 1
Link to comment
Share on other sites

A couple new bugs for you, both in the UI for creating/editing an item:

1) CMD+S doesn't save (you have to use the SAVE button)

2) In Mulitline fields you've created yourself (i.e., in your own custom template), the text doesn't wrap in the Edit view, so if you type a line longer than the width of the field, you can't see what you're typing:

         1037823559_Multilinetextwrapbroken01-EDITview.png.8020ca3a5d1356355fb6d2ca788e8250.png

 

It does textwrap just fine when viewing the item:

         1531189212_Multilinetextwrapbroken02-DISPLAYview.png.42aea0155c533c9b207498256d9df973.png

Edited by 100 Watt Walrus
Link to comment
Share on other sites

Hi @100 Watt Walrus

Thanks for sharing your feedback.

10 hours ago, 100 Watt Walrus said:

1) CMD+S doesn't save (you have to use the SAVE button)

 

This issue has been fixed and you will get it in the next update.

10 hours ago, 100 Watt Walrus said:

2) In Mulitline fields you've created yourself (i.e., in your own custom template), the text doesn't wrap in the Edit view, so if you type a line longer than the width of the field, you can't see what you're typing:

I've noted it down and notified the dev team to look into it.

9 hours ago, 100 Watt Walrus said:

Feature request: Would like to be able to copy custom templates from one Vault to another — although I do understand how that might be easier said than done. :) (Don't cross the streams!

Noted and forwarded to the concerned desk.

Cheers!

Link to comment
Share on other sites

On 9/7/2018 at 3:28 PM, Bibon said:

I exported my Enpass5 Vault to import it into Enpass6 Beta (187) and I have "Invalid TOTP Secret" for several entries (amazon, snapshat, dropbox, firefox, google...). What is it due to?
What should I do ?

When you see "Invalid TOTP Secret", go into Edit mode and go to the field.

There you will probably see a line similar to the following:

image.thumb.png.1a2072e356195b6315b3a4898d6b032f.png

Here you have two choices:

  1. Edit the otpauth:// URI to put the issuer before the secret:
    • image.thumb.png.30c7876b8a4c6f7c19b0662c55b98e15.png
  2. Or delete everything except the secret itself:
    • image.thumb.png.afcc091a262a9540a37282f2ecd2ad21.png

At this point your TOTP should start generating values.

Apologies for using images, but it seems Enpass does not like users helping one another... :-P

Edited by Eugéne
Link to comment
Share on other sites

On 9/12/2018 at 6:03 AM, Anshu kumar said:

Hi @JSF,

Thanks for writing in.

Please follow these steps to enable sync in Enpass 6.

  • Open Enpass --> Settings --> Vaults --> Tap Set up sync.

139821677_preview-chat-ScreenShot2018-09-12at2_54_27PM.png.63918a068ad60b30f1012926ee1e6ba5.png

NOTE: Currently there is some issue where WebDAV sync is not properly working and the fixed version will be available soon.

Thanks for your patience.

Thanks!

I just completely missed that.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...