Jump to content
Vikram Dabas

A new beta update of Enpass 6 is now available for Linux, macOS and Windows

Recommended Posts

Trying to solve the Logitech issue I discovered that Enpass6beta is bypassing some macOS setups. Under Mojave/System Preferences/General I have the following choices:

Show scroll bars: Always

Click in the scroll bar to: Jump to the next page

That works fine in the Finder and with other applications, but Enpass6beta is disregarding those choices. The scroll bar only shows when I click somewhere in the scroll bar column, and it disappears after a couple of seconds. And the cursor moves to the spots where I clicked instead of going down or up one page.

Some, myself included are not really pleased with the Mac version of Enpass6beta appearance being imported from the Windows side. It seems that you may also have imported things under the hood at the same time. I hope you can fix this.

Share this post


Link to post
Share on other sites
8 hours ago, fermati said:

Some, myself included are not really pleased with the Mac version of Enpass6beta appearance being imported from the Windows side. It seems that you may also have imported things under the hood at the same time. I hope you can fix this.

I'm with you. I hope the Mac version becomes something native instead of a port of the Windows version. It's not nearly intuitive or user-friendly enough as is. I'll probably keep using it because I've tried all the others, and Enpass is the only pw manager I like. But I really want to recommend it to friends and family, and I won't be able to do that unless it's Mac-friendly enough for my Dad to wrap his head around without help.

Share this post


Link to post
Share on other sites

Interesting, some of us Windows users think that the UI imports too much from the mobile versions, and hence doesn't fit well with Windows UI idioms, expectations or usability (e.g. slideout panels from than popup dialogs for editing, and I still can't get used to when to go for the horizontal line menu versus the cog menu...)

Matthew

  • Thanks 1

Share this post


Link to post
Share on other sites
On 10/5/2018 at 10:12 AM, Axxel H said:

On Mac build 220 appears to break most (all?) import options. Importing from 1Password PIF or any of the CSV options (1Password or "Pre-fomatted CSV") returns "Something went wrong, error -9998".

I've done the "clear everything" option from advanced, and attempted to import again no change in behavior. Anything else I should try or am I stuck waiting for the next beta?

I've been looking forward to trying out folder sync, but if I can't move my data in bulk its not practical to test.

Exactly the same with me. The app is currently unusable for me. Very much considering moving away from 1Password if this can be resolved quickly.

Thanks for all your hard work!

Share this post


Link to post
Share on other sites
5 hours ago, AdrenalineX said:

Thanks for all your hard work!

Just wanted to second this, since mostly what we're all doing here is reporting bugs and things we wish were different.

Still very excited about v6 and very much looking forward to helping more as it progresses toward a finished product. I recognize that may take time for a small development team working on a project that maybe doesn't bring in enough money for it to be a primary source of income — I'm a part of one of those teams myself.

Share this post


Link to post
Share on other sites

The dark mode looks superb on the new Enpass v6 beta B| Just now the blue really doesn't fit anymore. But that may just be my taste. Maybe there will be an option for different (or no) colors in later betas.

Thanks also for favicon support! 

 

Share this post


Link to post
Share on other sites
On 10/21/2018 at 6:50 PM, fermati said:

Some, myself included are not really pleased with the Mac version of Enpass6beta appearance being imported from the Windows side. It seems that you may also have imported things under the hood at the same time. I hope you can fix this.

 

On 10/22/2018 at 3:47 AM, 100 Watt Walrus said:

I'm with you. I hope the Mac version becomes something native instead of a port of the Windows version. It's not nearly intuitive or user-friendly enough as is. I'll probably keep using it because I've tried all the others, and Enpass is the only pw manager I like. But I really want to recommend it to friends and family, and I won't be able to do that unless it's Mac-friendly enough for my Dad to wrap his head around without help.

 

On 10/22/2018 at 2:03 PM, mdovey said:

Interesting, some of us Windows users think that the UI imports too much from the mobile versions, and hence doesn't fit well with Windows UI idioms, expectations or usability (e.g. slideout panels from than popup dialogs for editing, and I still can't get used to when to go for the horizontal line menu versus the cog menu...)

Matthew

The desktop beta versions of Enpass 6 are a disgrace to every other desktop app that I have ever used on Windows. It is extremely keyboard and mouse hostile. The grotesque button placement, the slide out panels, the touch oriented layout. The desktop version just copies everything that is ugly and horrible and uncomfortable to use in the old 1Password 6, all those decisions which AgileBits itself mostly moved away from in the 1Password 7 versions and later. 

 

What I really loved about Enpass was that It was a great desktop app that looked and worked natively cross platform, and that it also had Android and iOS apps. It was exactly like 1Password 4 on Windows used to be. That is why I always recommended my family, friends and colleagues to use Enpass. 

 

But with the beta versions of Enpass 6 for Desktop, all of those good qualities have been destroyed. 

More than 3 beta versions have been released, and they still have not managed to fix basic scrolling and button placement.

They have not implemented a proper menu bar and they have not moved away from the horrible and keyboard and mouse hostile tablet user interface.

Last I checked, there were also a lot of bugs with right clicking as well. 

 

So basically everything that makes a proper and usable desktop app is either not going to be implemented, or not going to work properly. 

There is no hope for fixing it anymore. There is no reason to use a mobile version of a product that is awful to use on desktop.

Everyone who wants for a good password manager should switch to another service. 

Share this post


Link to post
Share on other sites
On 10/23/2018 at 7:20 PM, phg said:

There is no hope for fixing it anymore. ...Everyone who wants for a good password manager should switch to another service. 

Welcome back from the future, where you've seen the final version of Enpass 6 and can report on how bad it is...oh wait...

Yes, the UI redesign in v6 is bad. Most people here are trying to help make it better with constructive criticism, describing how and why the UI is problematic, and making suggestions for improvement. Beta testing is about squashing bugs and improving features first. Once an app's functionality is more stable, that's usually when you start working on polishing the UI.

If you don't want to help anymore, take your own advice. There are plenty of other password managers to choose from. Find one you like and stop telling strangers what the should and should not do.

Edited by 100 Watt Walrus

Share this post


Link to post
Share on other sites
On 10/22/2018 at 11:21 AM, AdrenalineX said:

Exactly the same with me. The app is currently unusable for me. Very much considering moving away from 1Password if this can be resolved quickly.

Thanks for all your hard work!

Has there been any update on this? I'm still unable to import 1Password data.1pif

Share this post


Link to post
Share on other sites
On 10/28/2018 at 5:45 AM, 100 Watt Walrus said:

Yes, the UI redesign in v6 is bad

Does the Enpass team agree with this statement? 

If so, then there is hope for improvement.

On 10/28/2018 at 5:45 AM, 100 Watt Walrus said:

Beta testing is about squashing bugs and improving features first.

Good UX is a feature. Bad UX is a bug. 

But it does not seem like anyone on the Enpass team acknowledges that the Frankentablet UI is a bug. On the contrary, in every complaint that is made they explicitly ignore all the complaints about this. 

Share this post


Link to post
Share on other sites
17 hours ago, phg said:

On the contrary, in every complaint that is made they explicitly ignore all the complaints about this. 

That's just not true. They explicitly said they will try to make the UI/UX more Mac-like, as people (myself included) have requested. Give them some time. If you don't have time, please, move along.

Share this post


Link to post
Share on other sites
On 11/1/2018 at 6:17 PM, phg said:

Good UX is a feature. Bad UX is a bug. 

...in every complaint that is made they explicitly ignore all the complaints about this. 

Your definition of "feature" and "bug" are both way off. Good UX is literally every feature combined. Bugs are unintended behavior.

As for UI — which is what you're actually taking issue with — that's a matter of design choices, and as kwitchibo said, the Enpass team has explicitly stated (especially in the previous thread about the first beta release for Mac) they will make UI changes for a more Mac-like experience. They haven't said when or what those changes will be, but they have said the issue will be addressed.

If you want to ask why the Enpass team isn't chiming in more often about the UI complaints, I'd say that's a legitimate question. It would be nice if they were more responsive here. But given that they seem to reply in bursts, and given my experience on small software teams where we've done the same, my educated guess is that they're choosing to focus their limited time on improving the app for its next beta rather than replying to every issue raised here.

Similarly, given my experience on small software teams, improvements to the UI are the last step in the process — and in this case, making the app more Mac-like is going to be a major overhaul, so I'm very happy to have them working on fixing actual bugs first. If a team has enough people that UI is someone's (or many someones') only job, then yeah, it gets handled in parallel with the under-the-hood work. But that's pretty clearly not the case here.

Let the Enpass team take care of the unintended behaviors and put finishing touches on the features. Once the app is working as intended, then I expect we'll be hearing about the Mac-ification.

But if you don't have the patience for that, what are you even doing in a thread about beta software?

 

Share this post


Link to post
Share on other sites

A few issues and suggestions from a session of entering new items in Enpass 6 for Mac below. Forgive me if any of these are repeats (some may even be repeats of myself!).

1) In addition to being able to make your own default template (as mentioned before), the app needs the ability to delete templates. There are dozens of templates I will literally never use, and they're getting in the way of quickly accessing my custom templates, which are the only ones I'll ever use.

2) Custom templates should appear at the top of the Templates list, not the bottom. Clearly if you've made a custom template, you're going to want to use it with some frequency. At the very least, they should be distributed alphabetically amongst all the others, not at the bottom.

3) ESC key should clear the search field. It does not. As near as I can tell, the only way to clear the search field is to physically click the (X).

4) On a Mac, if you have the main window open and you use the Mac's built-in "Hide" feature (CMD+H, universally), the Enpass6 window does not hide, but rather closes.

5) I continue to have problems syncing. It used to be that if I quit out of Enpass6 and re-launched it, all my vaults would sync successfully on relaunch. But now I have 2 vaults that won't sync at all, and one that fails more often than it succeeds. Previously the team had suggested that I "please re-connect the Google Drive sync and let me know  if the problem persists." That did work, but the problem has returned, and now it's both Google Drive and Dropbox.

6) When using "Choose Icon," it takes way too long for the icon gallery to load. The loading graphic just spins and spins for 20-40 seconds.

7) When adding tags, after adding one, if you hit TAB, an additional tag field is created, but it is not selected, so you have to then manually click in it before you can add your next tag. But if you hit ENTER instead, an additional tag field is created and selected, so you can just begin typing. (This is in addition to the previously reported problem of  there not being any auto-fill suggestions for previously created tags, which runs the risk of users accidentally creating multiple tags for the same thing — e.g., Shop and Shopping because when you type in "Sho"... nothing pops up to suggest the tag you've already created.)

 

Share this post


Link to post
Share on other sites
8 hours ago, kwitchibo said:

That's just not true. They explicitly said they will try to make the UI/UX more Mac-like, as people (myself included) have requested. Give them some time. If you don't have time, please, move along.

They haven't said anything about improving the design on Windows.

In all previous feedback I have given, they answered all the points raised except the ones about the app design. 

The app doesn't feel foreign and horrible to use with keyboard and mouse on the Mac. It feels bad on Windows as well, because the "UWP" look they adopted, with hamburger menus and weird button placement and lack of right click menu, is designed primarily for tablets. 

1 hour ago, 100 Watt Walrus said:

But if you don't have the patience for that, what are you even doing in a thread about beta software? 

It's not about patience. I'm just making it very clear that the app being great to use with keyboard and mouse is very important to me as a user, and that the Enpass team does not seem to care about this enough, given the current design of the app and given their answers to feedback on the Windows app design.

Edited by phg

Share this post


Link to post
Share on other sites

I'm on a roll tonight...

On the subject of the UI, I don't have a problem with waiting for the bugs and kinks to be worked out before the app gets a proper Mac skin, but I'd like to address a few general usability issues that I think apply to Mac and Windows. (Again, forgive me if I'm repeating anything mentioned upthread.)

- Broadly, the design of the app is too much like mobile for a desktop UI. Example: navigating the settings is a hassle. There's too much nesting of sub-sections. If the settings opened in their own window (like Enpass 5), they could be much more quickly navigated. Also, there are parts of the UI from which its impossible to reach the settings directly. For example, if you're in the Add Item sidebar, CMD+[comma] does not bring up the settings.

- As others have mentioned, having the "edit" icon (pencil) in the middle of the header is counter-intuitive. It should be on the "card" along with "favorite" and "more."

- Editing any given Item should take place in the same part of the screen as viewing the item. Having the Edit UI roll out from the right is problematic because it becomes impossible to interact at all with the rest of the app. For example, while editing you want to add a few Tags, but you're not sure of all the tags you want to use — but it's impossible to scroll the sidebar and look at all your tags because everything "behind" the edit overlay is grayed out. The editing should happen right there in the "card."

- In the sidebar, if you mouseover the Categories header, you get a "..." that brings up an "Edit Categories," but if you mouseover the Tags header, you get a "+" that brings up an "Add tag" overlay. Instead Settings > Customize should include a Tags area where you can add, edit, hide, and delete tags — and the sidebar's Tags header should behave the same way as the Categories header. UI consistency.

I'll probably have more later.

  • Thanks 1

Share this post


Link to post
Share on other sites

Password Audit bugs:

- Sometimes when you click on one Item, then click on another, you end up with all the items you've clicked selected together, instead of switching to the second, third, fourth one you've clicked — in other words, it's behaving like a SHIFT+click instead of just click.

Steps to recreate:

  1. Password Audit > Identical
  2. Select any Item in the Items column
  3. Click that item's show password button
  4. Now click on any other Item in the Items column

RESULT: The original item and the new item are now both selected

      5. Now click additional items

RESULT: Every item you click remains selected — it's impossible to click any one item to see its details

The only way out of this is to quit the app and relaunch it. This happens in Password Audit > Weak too.

 

- At the top of "Identical," I'm seeing several Items listed under "******" (just stars, not the first two characters followed by stars, like all the other "identical" sections below that first section), and none of the items listed actually under "******" have identical passphrases, or even similar passphrases. No idea how to recreate this one without sending you my vault. :)

 

Share this post


Link to post
Share on other sites
41 minutes ago, phg said:

They haven't said anything about improving the design on Windows.

In all previous feedback I have given, they answered all the points raised except the ones about the app design. 

The app doesn't feel foreign and horrible to use with keyboard and mouse on the Mac. It feels bad on Windows as well, because the "UWP" look they adopted, with hamburger menus and weird button placement and lack of right click menu, is designed primarily for tablets. 

It's not about patience. I'm just making it very clear that the app being great to use with keyboard and mouse is very important to me as a user, and that the Enpass team does not seem to care about this enough, given the current design of the app and given their answers to feedback on the Windows app design.

Roger that. It wasn't clear to me you were talking about Windows, but that may have been a reading-comprehension failure on my part. And I think you're right, the Enpass team hasn't said anything about addressing usability issues on Windows. I was a bit surprised that this release got a single thread for Mac, Windows, and Linux — but then that may be a function of the Enpass team's desire to focus on bugs at this juncture. Granted, it would have been helpful had that been made clear.

I'm in 100% agreement that the whole UI concept needs a revisit (I just posted a few bullet points of my own on that front). Porting an Android UI to desktops isn't going to get the job done, and it would be reassuring to see the Enpass team address this with a "don't worry, folks, we'll get to it ASAP."

  • Thanks 1

Share this post


Link to post
Share on other sites

Just to add something to the UI-part (I hope nobody else has mentioned it yet):

  • In the macOS-beta, blue text on dark background is almost impossible to read. Check any URL-link in any entry while you are using dark mode. I am almost certain this is already on the team's list, just wanted to make sure though.

Something new:

  • I'm not sure whether this happened with the previous beta (again, macOS), but right now the app is a real CPU hog with about 50% of CPU usage. I noticed it after about 10 minutes of working with the app. I use Mojave (10.14.1).

 

I would also like to request the separation of threads in this forum. One for each platform. We've seen what kind of confusion can come up.

 

And maybe a little more responsiveness would be good too. Hint: that's a general suggestion to the Enpass-team ;)

 

 

 

Share this post


Link to post
Share on other sites

Hey Guys,

Thanks for the input regarding UI.

I would like to share that we do have plans to improve the UI of the Enpass on the Mac platform but at the moment I can't assure you any ETA.

On 11/3/2018 at 8:43 AM, 100 Watt Walrus said:

1) In addition to being able to make your own default template (as mentioned before), the app needs the ability to delete templates. There are dozens of templates I will literally never use, and they're getting in the way of quickly accessing my custom templates, which are the only ones I'll ever use.

 

Already in our roadmap and will be available with the subsequent update.

On 11/3/2018 at 8:43 AM, 100 Watt Walrus said:

2) Custom templates should appear at the top of the Templates list, not the bottom. Clearly if you've made a custom template, you're going to want to use it with some frequency. At the very least, they should be distributed alphabetically amongst all the others, not at the bottom.

1

Noted and forwarded to the concerned desk for further improvement.

On 11/3/2018 at 8:43 AM, 100 Watt Walrus said:

3) ESC key should clear the search field. It does not. As near as I can tell, the only way to clear the search field is to physically click the (X).

 

 

Noted and forwarded to the concerned desk.

On 11/3/2018 at 8:43 AM, 100 Watt Walrus said:

 4) On a Mac, if you have the main window open and you use the Mac's built-in "Hide" feature (CMD+H, universally), the Enpass6 window does not hide, but rather closes.

 

1

Noted and forwarded to the concerned desk.

On 11/3/2018 at 8:43 AM, 100 Watt Walrus said:

5) I continue to have problems syncing. It used to be that if I quit out of Enpass6 and re-launched it, all my vaults would sync successfully on relaunch. But now I have 2 vaults that won't sync at all, and one that fails more often than it succeeds. Previously the team had suggested that I "please re-connect the Google Drive sync and let me know  if the problem persists." That did work, but the problem has returned, and now it's both Google Drive and Dropbox.

 

Noted and forwarded to the QA team to look into it.

On 11/3/2018 at 8:43 AM, 100 Watt Walrus said:

 6) When using "Choose Icon," it takes way too long for the icon gallery to load. The loading graphic just spins and spins for 20-40 seconds.

 

 

Noted and forwarded to the QA team to look into it.

On 11/3/2018 at 8:43 AM, 100 Watt Walrus said:

7) When adding tags, after adding one, if you hit TAB, an additional tag field is created, but it is not selected, so you have to then manually click in it before you can add your next tag. But if you hit ENTER instead, an additional tag field is created and selected, so you can just begin typing. (This is in addition to the previously reported problem of  there not being any auto-fill suggestions for previously created tags, which runs the risk of users accidentally creating multiple tags for the same thing — e.g., Shop and Shopping because when you type in "Sho"... nothing pops up to suggest the tag you've already created.)

 

Noted.

Thanks for your co-operation.

 

Share this post


Link to post
Share on other sites
On 11/3/2018 at 9:34 AM, 100 Watt Walrus said:

Password Audit bugs:

- Sometimes when you click on one Item, then click on another, you end up with all the items you've clicked selected together, instead of switching to the second, third, fourth one you've clicked — in other words, it's behaving like a SHIFT+click instead of just click.

 

I have noted it down and forwarded to the QA team to look into it.

Thanks!

Share this post


Link to post
Share on other sites

Hey @kwitchibo 

Thanks for sharing your feedback.

On 11/4/2018 at 2:08 PM, kwitchibo said:

In the macOS-beta, blue text on dark background is almost impossible to read. Check any URL-link in any entry while you are using dark mode. I am almost certain this is already on the team's list, just wanted to make sure though.

Noted and notified the dev team to look into it.

On 11/4/2018 at 2:08 PM, kwitchibo said:

I'm not sure whether this happened with the previous beta (again, macOS), but right now the app is a real CPU hog with about 50% of CPU usage. I noticed it after about 10 minutes of working with the app. I use Mojave (10.14.1).

Please share some more info so that we can investigate further.

  • The number of items and Attachments saved in Enpass.
  • Are you facing this problem in any specific scenario like when you wake the system from the sleep or any other?

 

On 11/4/2018 at 2:08 PM, kwitchibo said:

I would also like to request the separation of threads in this forum. One for each platform. We've seen what kind of confusion can come up.

 

And maybe a little more responsiveness would be good too. Hint: that's a general suggestion to the Enpass-team ;)

 

Sorry about that! We will take care of it.

Thanks for your co-operation.

Share this post


Link to post
Share on other sites

A bit of an oddity with favicon fetching. On my T-Mobile account Item, the URL I had in the item is http://account.t-mobile.com. When I clicked the icon and selected Use Favicon, literally nothing happens. No progress spinner on the generic icon, no attempt to reach the site (I know because Little Snitch doesn't alert me to an outgoing connection). But if I change the URL to just https://t-mobile.com, it works fine.

Also, Favicon fetching doesn't work for coveredca.com (progress spinner just spins and spins, while Enpass chews up a lot of CPU.

Share this post


Link to post
Share on other sites

New bug: Sometimes it's not possible to scroll within the Edit UI. For example, when I bring up a new Default template, I can't get to anything below the Tags field, unless I make the window bigger. No scrolling, no scrollbars.

Quitting and relaunching Enpass fixes the problem. But it's happened at least 3 times in the last week.

Haven't been able to discern how this problem comes about, but will provide steps to recreate if I can figure them out.

Running El Capitan (10.11.6) on MacBook Pro Late 2009.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...