Jump to content
qgvrt

Accessibility Autofill doesn't fill fields on Android 10

Recommended Posts

Hi, I have noticed Autofill using Accessibility doesn't work anymore on my Galaxy S10+, after updating to Android 10 / OneUI 2.0.

I use Brave browser so I rely on the Accessibility route only, as it is not compatible with the Android Autofill service. I still have another phone on Android 9 / OneUI 1.5, which doesn't have the issue below:

When trying to use Autofill on a website, I tap the Autofill notification, the Enpass biometric / login dialog appears normally, I pick the right login account from the list, it switches back to Brave. Normally at this point, it would fill the login fields correctly. On Android 10, this leaves the fields empty, nothing happens.

I have tried to remove Enpass from the "optimised from battery" list, then reset my phone's settings, uninstalled / reinstalled both Enpass and Brave... And finally factory reset my phone, nothing worked.

Is anyone else having the issue? Don't want to keep manually inputting passwords, switch to another password manager, or browser...

Share this post


Link to post
Share on other sites

Also note this issue isn't exclusive to Brave, it's *any* app relying on the Accessibility Autofill.

For example, I could replicate the same bug with Spotify - Enpass didn't fill the email/password fields like it used to. 

Edited by qgvrt

Share this post


Link to post
Share on other sites

@qgvrt,

Thank you for pointing this out. Please note, we do not currently support the auto-fill functionality on Brave browser. Apologies on that!

We are currently working on fine tuning the Auto-fill issues in Android on all the apps and websites and we hope most issues related to auto-fill will be fixed in the upcoming updates. 

On 1/29/2020 at 3:56 PM, qgvrt said:

For example, I could replicate the same bug with Spotify - Enpass didn't fill the email/password fields like it used to. 

We (un)fortunately couldn't reproduce this with Android 8 and 9 at our end. We'll have to check the behaviour with Android 10.

Share this post


Link to post
Share on other sites

Thanks for the reply, Tahreem.

I wasn't bothered by the lack of support for Android autofill in Brave, as the Accessibility Autofill has always worked well enough for me (albeit not perfectly). The fact that this secondary solution doesn't work anymore system-wide is definitely the real issue. What used to be a fairly smooth user experience is now super cumbersome.

I'll keep troubleshooting and see if this is a very specific issue on my end, as I couldn't find any other similar complaints. Good to hear you're working on fine-tuning autofill, I'll be on the lookout for updates to the app.

Please let us know if you do test the app further on Android 10 / OneUI 2! Thanks

Share this post


Link to post
Share on other sites

Hi @qgvrt,

Thanks for writing back in.

On 1/31/2020 at 9:04 PM, qgvrt said:

Please let us know if you do test the app further on Android 10 / OneUI 2! Thanks

We had already tested the issue on Android 10 and will be testing the same in OneUI. We will update you once we have further information.

Thanks for your co-operation.

Share this post


Link to post
Share on other sites

Awesome! Thanks for looking into it and for the continued updates. Looking forward to the fix :)

 

I'll update here when this is fixed in the future. Thanks! 

  • Like 1

Share this post


Link to post
Share on other sites

This has bothered me since months, as I was one of the Beta users of Samsung's Android 10 update. Glad I am not alone here, and it indeed does not restrict itself to a certain browser or app. If I try to autofill via the notification icon it won't work, on some fileds in some apps there is a 'Fill with Enpass' option that then at least fills that respective field at times, but that is a handful of hundreds of failed autofills. So hoping you'll be able to fix it soon :) .

Share this post


Link to post
Share on other sites

Hi @eno,

Sorry for the inconvenience caused to you.

Please share the following details so that we can investigate where the problem could be.

  •  On which devices and OS versions are you using Enpass?
  • Which Enpass version are you using?
  • If possible, let us know are you facing this issue on any particular website? If Yes, please share details with us.

Share this post


Link to post
Share on other sites
On 2/28/2020 at 12:19 PM, Pratyush Sharma said:

Hi @eno,

Sorry for the inconvenience caused to you.

Please share the following details so that we can investigate where the problem could be.

  •  On which devices and OS versions are you using Enpass?
  • Which Enpass version are you using?
  • If possible, let us know are you facing this issue on any particular website? If Yes, please share details with us.

Hi @Pratyush Sharma,

  • Samsung Galaxy S10 (European model), Android 10 from Beta until the very current (security patch level Feb 1) - happens since the first Android 10 Beta
  • Latest Beta, but happens since the first Android 10 Beta for the Galaxy S10
  • Happens on any website - Autofill through notifications doesn't work, I can tap the notification, unlock Enpass, choose the right entry, but no field is being filled (Android Chrome Beta, normal Chrome as well). On some websites I can use per-field filling through the 'Fill with Enpass' option that pops up.
  • Like 1

Share this post


Link to post
Share on other sites

Hi @qgvrt and @eno

Sorry for the trouble you are going through.

We have just released an updated version of Enpass v6.4.0. Could you please update the app from the Play Store and check if you are still encountering issue with the app.

Also, I am glad to share that now Enpass do support Brave browser.

Thanks.

Share this post


Link to post
Share on other sites

Hey @Garima Singh

Thanks for the heads up. I have downloaded the update and tested it extensively. First of all, congrats on supporting Brave. I have tried the Android Autofill which worked well in my experience, it seems more reliable than before!

However, when trying the Accessibility Autofill (tapping the notification), the fields still aren't being filled. This was tested on multiple websites, using the latest stable versions of Brave, Chrome and Microsoft Edge browsers, on Samsung Galaxy S10+ Android 10 / OneUI 2.0 (latest stable Feb 1st patch). Note that when tapping the notification, the right Enpass entry shows up, so it recognises the website I am trying to log in to.

Hope this helps - let me know if I can help further.

Edited by qgvrt
added phone model

Share this post


Link to post
Share on other sites
10 hours ago, Garima Singh said:

Hi @qgvrt and @eno

Sorry for the trouble you are going through.

We have just released an updated version of Enpass v6.4.0. Could you please update the app from the Play Store and check if you are still encountering issue with the app.

Also, I am glad to share that now Enpass do support Brave browser.

Thanks.

I just had a mixed experience. With the latest version, I could use Enpass Autofill through notification on exactly one page in an overlay (arturia.com), but not on any other than that. Weird.

Share this post


Link to post
Share on other sites

I have Android 10 (pixel 3) and the 6.4.1.329 build installed, but autofill through accessibility is now completely non-functional. I don't get the notification on a login screen in any app. Android autofill will sometimes prompt me, but it never recognizes the app. The enpass keyboard does not recognize websites in opera or chrome, and even after selecting the login, still will not autofill the fields.

 

Massive regression, folks.

Share this post


Link to post
Share on other sites

@Jrdc

Welcome to the forums!!
Could you try disabling the Autofill under Enpass settings, kill the app, re-enable the Auto-fill and check if the auto-fill works on your device. You could also follow the help center article here to auto-fill on your device.

Thanks.

Share this post


Link to post
Share on other sites

I have also issues with autofill. On many apps the enpass dialog to fill the input fields is not shown. I disabled and enabled autofill a couple of times. I tried 1Password to see if it's an issue in general or only related to enpass. 1password works perfect here.
My Setup is:

  • Pixel 4
  • Android 10 (Build: QQ2A.200305.003
  • Latest version of Enpass

Share this post


Link to post
Share on other sites

Same here. Autofill does not work on any website or app. Reported that issue twice via the "E-mail Us" function in the app. I will try it again, here in this forum ...

Enpass Version: 6.4.2.337

Samsung Galaxy S10

Android 10, Build No: QP1A.190711.020

Tested Browsers: Chrome, Microsoft Edge, Opera etc.

 

Please take a look into this. The issue is almost 3 months old.

Without autofill the app is pretty useless. And it's not like the app is free to use...

Edited by maximus

Share this post


Link to post
Share on other sites
Just now, maximus said:

Same here. Autofill does not work on any website or app. Reported that issue twice via the "E-mail Us" function in the app. I will try it again, here in this forum ...

Enpass Version: 6.4.2.337

Samsung Galaxy S10

Android 10, Build No: QP1A.190711.020

Tested Browsers: Chrome, Microsoft Edge, Opera etc.

 

Please take a look into this. The issue is almost 3 months old.

Without autofill the app is pretty useless. And it's not like the app is free to use...

The topic is, the problem is much older, ever since the first Android 10 Betas actually.

Share this post


Link to post
Share on other sites

I am having the exact same issues as reported here. My software is the same as user Maximus:

Enpass Version: 6.4.2.337

Samsung Galaxy S10

Android 10, Build No: QP1A.190711.020

I hope this can be fixed soon

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...