Jump to content
qgvrt

Accessibility Autofill doesn't fill fields on Android 10

Recommended Posts

Hi, I have noticed Autofill using Accessibility doesn't work anymore on my Galaxy S10+, after updating to Android 10 / OneUI 2.0.

I use Brave browser so I rely on the Accessibility route only, as it is not compatible with the Android Autofill service. I still have another phone on Android 9 / OneUI 1.5, which doesn't have the issue below:

When trying to use Autofill on a website, I tap the Autofill notification, the Enpass biometric / login dialog appears normally, I pick the right login account from the list, it switches back to Brave. Normally at this point, it would fill the login fields correctly. On Android 10, this leaves the fields empty, nothing happens.

I have tried to remove Enpass from the "optimised from battery" list, then reset my phone's settings, uninstalled / reinstalled both Enpass and Brave... And finally factory reset my phone, nothing worked.

Is anyone else having the issue? Don't want to keep manually inputting passwords, switch to another password manager, or browser...

Share this post


Link to post
Share on other sites

Also note this issue isn't exclusive to Brave, it's *any* app relying on the Accessibility Autofill.

For example, I could replicate the same bug with Spotify - Enpass didn't fill the email/password fields like it used to. 

Edited by qgvrt

Share this post


Link to post
Share on other sites

@qgvrt,

Thank you for pointing this out. Please note, we do not currently support the auto-fill functionality on Brave browser. Apologies on that!

We are currently working on fine tuning the Auto-fill issues in Android on all the apps and websites and we hope most issues related to auto-fill will be fixed in the upcoming updates. 

On 1/29/2020 at 3:56 PM, qgvrt said:

For example, I could replicate the same bug with Spotify - Enpass didn't fill the email/password fields like it used to. 

We (un)fortunately couldn't reproduce this with Android 8 and 9 at our end. We'll have to check the behaviour with Android 10.

Share this post


Link to post
Share on other sites

Thanks for the reply, Tahreem.

I wasn't bothered by the lack of support for Android autofill in Brave, as the Accessibility Autofill has always worked well enough for me (albeit not perfectly). The fact that this secondary solution doesn't work anymore system-wide is definitely the real issue. What used to be a fairly smooth user experience is now super cumbersome.

I'll keep troubleshooting and see if this is a very specific issue on my end, as I couldn't find any other similar complaints. Good to hear you're working on fine-tuning autofill, I'll be on the lookout for updates to the app.

Please let us know if you do test the app further on Android 10 / OneUI 2! Thanks

Share this post


Link to post
Share on other sites

Hi @qgvrt,

Thanks for writing back in.

On 1/31/2020 at 9:04 PM, qgvrt said:

Please let us know if you do test the app further on Android 10 / OneUI 2! Thanks

We had already tested the issue on Android 10 and will be testing the same in OneUI. We will update you once we have further information.

Thanks for your co-operation.

Share this post


Link to post
Share on other sites

Awesome! Thanks for looking into it and for the continued updates. Looking forward to the fix :)

 

I'll update here when this is fixed in the future. Thanks! 

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...