Jump to content
Enpass_account

Fingerprint / biometrics issue

Recommended Posts

Hi Enpass-Team,

I have a new phone (Android 9) and a issue with my fingerprint.

After every phone-restart, the app have these  problem:

20200803-193345-b147b404a8d1a9c3.jpg

 

What does it exactly mean?

My system: LineageOS 16 (Android 9) with only fingerprint as biometrics

App version: 6.5.0.380

Edited by Enpass_account

Share this post


Link to post
Share on other sites

Hi @Enpass_account

I am going to assume that your phone has been rooted to allow you to install LineageOS, then I am going to guess that Enpass looks at the Firmware/OS after a reboot sees that it is rooted and for safety disables fingerprint biometrics.

Can you de-root the phone and then see what happens?

  • Thanks 1

Share this post


Link to post
Share on other sites
7 hours ago, Dentonthebear said:

Hi @Enpass_account

I am going to assume that your phone has been rooted to allow you to install LineageOS, then I am going to guess that Enpass looks at the Firmware/OS after a reboot sees that it is rooted and for safety disables fingerprint biometrics.

Can you de-root the phone and then see what happens?

Thank you for your reply!
I will test it.
FYI: My old phone (stock rom Android 8) has been rooted too and no issues.

Edited by Enpass_account

Share this post


Link to post
Share on other sites

Model: QX1000

Phone: Pro1 

Manufacturer: f(x)tec

Software: Android 9 (LineageOS 16)

Unlock with fingerprint -> problem after every phone restart. No difference between rooted with Magisk, rooted with Magisk and hide root status or not rooted. No other android app (unlock with fingerprint) has these issue.

Thx for your help!!!

Share this post


Link to post
Share on other sites

Hi @Enpass_account,

Thanks for writing in.

In Enpass biometrics gets disable due to five unsuccessful attempts or there are some changes made in the device setting. Please follow these troubleshooting steps and share your findings.

  • Remove all fingerprints from the device settings.
  • Add one fingerprint and now enable in Enpass.

If the problem persists, please do let me know are you using custom ROM.

  • Thanks 1

Share this post


Link to post
Share on other sites
On 8/5/2020 at 12:31 AM, Pratyush Sharma said:

Hi @Enpass_account,

Thanks for writing in.

In Enpass biometrics gets disable due to five unsuccessful attempts or there are some changes made in the device setting. Please follow these troubleshooting steps and share your findings.

  • Remove all fingerprints from the device settings.
  • Add one fingerprint and now enable in Enpass.

If the problem persists, please do let me know are you using custom ROM.

OP didn't say this happens after unsuccessful attempts, but after he restarts his phone. Why do companies constantly reply with random "solutions" that have nothing to do with the actual problem?

I came to post this myself, but my phone is unrooted, and I didn't have any unsuccessful attempts. Btw, Bitwarden doesn't disable biometrics after a phone restart like Enpass.

Edited by Pete

Share this post


Link to post
Share on other sites

Hi @Enpass_account @Pete

We are sorry for the trouble caused you.

Could you both please share the Enpass version you using on the same device?

@Pete Please share the device detail along with OS version on which you are having this issue? A screenshot, if possible would be great.

Thanks.

  • Thanks 1

Share this post


Link to post
Share on other sites
11 hours ago, Garima Singh said:

Hi @Enpass_account @Pete

We are sorry for the trouble caused you.

Could you both please share the Enpass version you using on the same device?

@Pete Please share the device detail along with OS version on which you are having this issue? A screenshot, if possible would be great.

Thanks.

Enpass: 6.5.0.390

OS: Umidigi F1, Anroid 9

Share this post


Link to post
Share on other sites
On 8/5/2020 at 6:31 AM, Pratyush Sharma said:

Hi @Enpass_account,

Thanks for writing in.

In Enpass biometrics gets disable due to five unsuccessful attempts or there are some changes made in the device setting. Please follow these troubleshooting steps and share your findings.

  • Remove all fingerprints from the device settings.
  • Add one fingerprint and now enable in Enpass.

If the problem persists, please do let me know are you using custom ROM.

After a normal reboot, I unlocked my phone without finger and opened enpass, but it doens´t work.
I cleaned all my fingerprints before I contact you :-)
Custom Rom: Lineage OS 16 (Android 9)

Share this post


Link to post
Share on other sites
22 hours ago, Garima Singh said:

Hi @Enpass_account @Pete

We are sorry for the trouble caused you.

Could you both please share the Enpass version you using on the same device?

@Pete Please share the device detail along with OS version on which you are having this issue? A screenshot, if possible would be great.

Thanks.

Version: 6.5.0.380, and then 6.5.0.390
I can say, my second Pro1 with original Android 9 (no root) (unlocked bootloader) has no problem to unlock Enpass with finger.
That means, the problem is between Lineage OS (similar with root or not root) (unlocked bootloader) and Enpass.

In the last days I tested a lot... sadly to confirm, it must be Lineage OS :(
But perhaps you have a hint or solution for it ^_^
FYI: I have so many apps (about ~10) which I unlock with my finger, only Enpass don´t want it ;)

Share this post


Link to post
Share on other sites

Hi @Enpass_account @Pete,

Due to security reasons, when any action is performed in device Biometric( like new Biometrics registered or removed), we internally disable the Biometrics from Enpass. As you mentioned, 

Quote

When the device is restarted the device removes fingerprints

This seems an OS-specific issue, and we can't do much about it.

Thanks!

  • Thanks 1

Share this post


Link to post
Share on other sites
4 hours ago, Pratyush Sharma said:

Hi @Enpass_account @Pete,

Due to security reasons, when any action is performed in device Biometric( like new Biometrics registered or removed), we internally disable the Biometrics from Enpass. As you mentioned, 

This seems an OS-specific issue, and we can't do much about it.

Thanks!

How come Bitwarden doesn't have this OS-specific issue?

When I restart my device, Enpass is the only app I need to manually re-enable biometrics, which doesn't even work until I go into the phone's fingerprint settings first. Every app I use (financial, social, security... BItwarden included) unlock with biometrics after a restart, without having to enable or do anything out of the ordinary. Why can't Enpass figure this out?

Share this post


Link to post
Share on other sites
13 hours ago, Pete said:

How come Bitwarden doesn't have this OS-specific issue?

 

I am facing the similar issue and found interesting behaviour, after rebooting the device fingerprint gets deleted.  You can check by Follow the mention steps:

a.  Add 5 fingerprints on the device settings.
b. Enable Biometrics in Enpass.
c. Reboot the Phone.
d When the device open --> Go to settings and check how many fingerprints are there? Does it display 5 fingerprints or any of them get deleted?

Share this post


Link to post
Share on other sites
10 hours ago, Samuela said:

I am facing the similar issue and found interesting behaviour, after rebooting the device fingerprint gets deleted.  You can check by Follow the mention steps:

a.  Add 5 fingerprints on the device settings.
b. Enable Biometrics in Enpass.
c. Reboot the Phone.
d When the device open --> Go to settings and check how many fingerprints are there? Does it display 5 fingerprints or any of them get deleted?

All my 5 fingerprints are deleted.

Share this post


Link to post
Share on other sites
10 hours ago, Samuela said:

I am facing the similar issue and found interesting behaviour, after rebooting the device fingerprint gets deleted.  You can check by Follow the mention steps:

a.  Add 5 fingerprints on the device settings.
b. Enable Biometrics in Enpass.
c. Reboot the Phone.
d When the device open --> Go to settings and check how many fingerprints are there? Does it display 5 fingerprints or any of them get deleted?

All 5 fingerprints are still there.

Share this post


Link to post
Share on other sites

Hi all,

Thanks for your inputs. Let us first have a look how biometric unlock in Enpass works, straight from our docs:

Quote

As soon as you enable Biometric from Enpass settings on your device, we create a Biometric authenticated, Enpass specific random encryption/decryption key in Android Keystore (accessible to Enpass only) and encrypt your master password using this key and store in private area in the device storage. This solution is highly secure because your master password is accessible only after it gets decrypted using the same key stored in the Android Keystore. And that key (in a usable format) can only be retrieved when you authenticate Enpass with your Biometric. This is so secure that even if someone gets access to your Android device passcode and legally adds his fingerprints in the phone, Android immediately invalidates all the encryption/decryption keys and makes them unusable. Even when in use, Enpass will detect this and will automatically disable Biometric in Enpass settings and removes your master password.

The invalidation of keys is done by OS itself and there little Enpass can do. Certain custom ROMs and variants of Android OS invalidate TEE keys on reboot. On some devices you will not be able to turn on Biometeric setting in Enpass.

Some ROMs also let you Enable biometrics without setting a Device PIN/Passcode first and that makes the TEE unprotected. If this the case with your device, please enable Device PIN/Passcode from device settings and share results.

@Pete Have you been able to use Enpass on this device without this problem before 6.5 update?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...