Jump to content
Enpass Discussion Forum

Problem with Firefox extension and Enpass 6.9.2


Recommended Posts

I have Windows 10 22H2, OS build 19045.3693
Firefox version: 118.0.2 (64-bit)
Enpass app version: 6.92.1562.0 downloaded from Microsoft Store
Enpass firefox extension version: 6.9.2
About a week ago , every time i am trying  to use Enpass extension in Firefox , to sign in to a website ,i  got the message:
  "Update Required.Extension is unable to connect with Enpass.You are using an older version of Enpass. The extension requires Enpass version  6.0.0 or later be installed first..Update Now"
Then I  press the " Update now" button and  go to the Enpass downloads page :https://www.enpass.io/downloads/, to download the extension again, while the extension already exists in my Firefox browser. After that extension works fine , but i must repeat that action  every time i open  Firefox browser.
I dont have any issue with Chrome or Edge.
I uninstalled and then reinstalled ,both app and extension but no result.
Please tell me what to do to fix this problem.
Thank you.firefox_CQBzL.thumb.jpg.24f9b7927d7f7d832b7d805c566749b6.jpg

Edited by tsipromadouro
Link to comment
Share on other sites

Hello Enpass staff,

For the past few days I've been getting an update required error message when using the Enpass extension on Firefox for MacOS.

The message is showing every few hours, and the only way to make the extension work is re-install the extension.

This helps temporarily, but the error message returns after I start working on the computer after it was in sleep mode.

My Enpass app and extension are updated to version 6.9.2. Firefox is on version 119.0.1 and MacOS is on version 14.1.1.

Hope you can fix this issue soon.

Screenshot 2023-11-21 at 10.30.43.png

  • Like 1
Link to comment
Share on other sites

Hi @all

Following a comprehensive examination of this matter, we wish to apprise you that we were able to replicate the issue. Regrettably, it seems there is no immediate solution for the reported concern. In light of this, we suggest employing the workaround outlined by our specialist team below. Additionally, Enpass has assigned a high priority to address this issue and is actively working towards a swift resolution. We value your support and patience.

Workaround: To address this issue, kindly restart the Firefox browser.

  • Like 1
Link to comment
Share on other sites


I should expose you my problem on windows 10 . It looks like the ones exposed above

Here is snapshot of the request of an identification code  from the firefox extension. But no displayed popup (from the application ?) to copy it.

In fact popup (from web...) are allowed  in the firefox configuration.

I hope you will fix this problem. Enpass worked so well and is so usefull.








Link to comment
Share on other sites

Hi @xaintrailles

It appears that the challenge you're encountering differs from the topic under discussion in this forum. Please consider trying the following steps, as they are likely to be beneficial in addressing your specific situation -

  1. Ensure that the latest version of Enpass is installed on your device and that the Enpass application is running in the background when using the browser extension. In addition, the “ Enable Extensions ” under the Browser settings of your Enpass application should also be enabled.

  2. I would also suggest checking that you have the latest version of browser installed , re-configuring the extension, and reinstalling it from here.

  3. Try clearing the cache and cookies of the browser.

  4. Ensure that you have allowed access to Enpass in your Antivirus/Firewall/VPN settings. Also try disabling them to see if the issue persists.

Link to comment
Share on other sites


I'm having a problem with the Enpass extension for Firefox running on SuSE Linux (Tumbleweed). Since one of the latest updates (either FF or Enpass) I always get the message that an update to Enpass is required when trying to login to a web site using the extension.

The message is (translated from German):

Update required
The extension cannot connect to Enpass.
You're using an old version of Enpass. The extension requires Enpass version 6.0.0 or above.

Of course I'm using the current version of Enpass. According to Help/About I'm using Enpass 6.9.2 (1563).

Firefox is version 119.0.1, Linux is SuSE Tumbleweed with Kernel 6.6.2. Extension says that it is v6.9.2 (updated Nov. 08, 2023).

When using Chromium the connection to Enpass works fine.



Edited by Oceanwaves
Link to comment
Share on other sites

  • Oceanwaves changed the title to Problem with Firefox extension and Enpass 6.9.2

Note that I am having the same issue on Linux PopOS 22.04. Initially I thought I had to reinstall the enpass and extension, but I have done that 3x already and the issue did not go away. One workaround so far is to make sure tha the enpass desktop is unlock and then disable the extension in firefox and then re-enable it. This seems to fix the issue temporary.

Link to comment
Share on other sites

5 minutes ago, sepahewe said:


Well, I'm using that one aswell and I haven't had this issues since the FF update to 120.0.1

Have you tried removing and adding the Add-On and see if this fixes it?

What are your extension settings? Here are mine:image.thumb.png.292d1a4af79838021e5448b748f43a5b.png


Edited by AnakinCaesar
words are hard
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy